How to access the engineering (Help Me!) screen on BlackBerry 10

The Help Me! Screen made its way to BlackBerry 10 from BlackBerry OS

By Bla1ze on 8 Apr 2013 12:39 am EDT
4
loading...
0
loading...
4
loading...

If you're into knowing the deeper details about your device, then you've likely accessed the engineering screen on your BlackBerry before. Also known as the escreen, it offers access to many diagnostic tools and just a general wealth of information about how things are working on your device, under the hood so to speak.

Remote logs, Cell tower information, APN information, Wi-Fi state, Vendor ID and more can be accessed through this menu -- it's an insanely useful tool for those who know what to do with the information or understand what it all means. With BlackBerry 10, this menu was pretty much assumed to of have gone missing, due to the fact the old methods of accessing it no longer worked.

As it turns out, it didn't go missing at all. It's still there, still accessible -- it's just been hidden a little bit deeper in BlackBerry 10 than in previous OS versions. Thanks to @nerdtalker@N301DQ and makaveli86 we now know how to do it and as such, are passing the info along.

  • The new method uses URL schemes so, in order to get things started you'll need to open your web browser and visit: escreen:// and then tap go.
  • Once loaded, visit this page and enter in the info needed, which is displayed after visiting the above URL - Device PIN, OS Version, and uptime. Duration can be set to whatever you wish from the available options. If set to 30 days, you won't need to repeat the process for 30 days etc.
  • Once the info is entered, a code will be generated. From there, two-finger swipe up to raise the keyboard and then input the code as shown. No new screen or box will show for the input, just enter the code. No text input box will appear, so you're typing it blindly and it's not case sensitive. The escreen will then change, offering you access.

It should go without saying that you shouldn't really access this page unless you know what you're looking for or doing but overall, I don't think much harm can come from it. If it's anything like BBOS, all changes you make should revert after a reboot but alas, that remains untested. In short, if you don't what you're doing in here then it's best to NOT change anything or even access it. If you like to tinker around though, then have it and let us know if anything cool comes out of it. Be sure to say thanks to @nerdtalker@N301DQ and makaveli86 as well, if you've been waiting for this to be uncovered. 

Reader comments

How to access the engineering (Help Me!) screen on BlackBerry 10

100 Comments

Kinda, but I missed the forum thread and apparently so did many others so.. thanks to makaveli86 as well, lol.

I've posted it to our russian forum more than a week ago... I was sure that you know about this trick.

There is no screen, once generated -- just type it in the screen that appeared after you input escreen://

 

you have to complete entering the code with in a minute of it being created because it is controlled by the uptime that is never stopping

I did it within 20 seconds of getting the code and it still doesn't work. I'm not sure what I am doing wrong.

I know this is a bit old, but I just tried again after my original 30-day code expired. Had to ignore case on the generated code: enter that code in the escreen window with just lowercase letters and numbers. Also, I had to type in my PIN as displayed, also lowercase letters, to generate the correct code in the first place.

Yeah that's exactly what I was looking for, but all I'm greeted with is: wcdma+lte,cdma1x+lte, cdma1x+evdo+lte, lte only, and what im currently on which is gsm+wcdma+lte

I was confused when I started seeing cdma and evdo.. and no option for gsm only

Posted via CB10 - FINALLY

if you put gsm only is it actually staying on EDGE? do you have to save settings somehow? doesn't seem to be having any effect on my end!

After you get the code go back to the engineering screen and blindly type it in hit enter. It should open up for you

I wonder what's the difference in the radio options for 103/104 versions? I find it weird that i have all...cdma only,evdo only,wcdma only,gsm only...gsm+cdma,cdma1x+evdo, lte only, wcdma+lte,cdma1x+lte,gsm+wcdma+lte,cdma1x+evdo+lte and this is stated as a 103 device

Posted via CB10

I tried a few times, didn't know if I just wasn't being quick enough or typing it wrong. Then I shut off Desktop mode in browser settings and it seemed to take. Enter the code on the escreen that popped up, not in the browser.

Posted from my Z10

"Enter the code in the screen that popped up not the browser" were you got the information from.
That did it for me thanks.
Sorry I can't send you a coffee using the CB10 app
Dang Att I turned off my LTE I don't have it were I live so why look for it 24/7 waisting battery!

Posted via CB10

Funny thing is I had to turn desktop mode ON for this to work. I wasted at least an hour messing with desktop mode off, not that you were to blame. That is, I already had desktop mode OFF.

An advice: if your Uptime looks like "-1234567" you should input it with "-" to get correct escreen key.

Worked, now where is a good guide to tell me how to use this screen? Have been messing around but don't want to get too crazy before I educate myself a little further...

Posted via CB10

I wonder if you can eliminate the tethering/hotspot restrictions using the e-screens, for those of us who have those restrictions on our plans. I am on VZ and I would love to have a hotspot/tethering option unlocked

Hey all it worked for me. I'm on vzw network. Calm down people. If you can't get into it you then have no business being in there

If you are using the CB10 app do not "Visit this page"

Instead hold press the link and select open link in browser. It should work then.

Posted via CB10

Tried it using my pc to generate code first, that failed. Then I used the phone to generate code which worked.

Posted via CB10

Enter the code in the screen that popped up not the browser" were you got the information from.
That did it for me thanks.

Posted via CB10

When I enter the General Radio screen, the default selected option for "Enabled RATs" is 'none.' Is this normal? When I switch it to any of the options it does not seem to have any effect on my radio.
Also if I exit and return the changes have reverted. Is there a way to save the settings for them to take effect?

Make sure you enter your pin exactly as shown on the screen, with the letters in lower case. Took me a dozen tries until I changed that.

LOL... The Z10 never ceases to amaze me! Who knew it has been monitoring my sanity all this time? Wonder what if does if it detects a crack in my sanity?

Posted via CB10

A quick google for sanity monitor comes out with an interesting definition. Could this be the cause of the random reboots some are experimenting??? i havent had any random reboots... but maybe someone can test it.

http://www.google.com/patents/US6665758
Software sanity monitor
US 6665758 B1
ABSTRACT
Disclosed is a Software Sanity Monitor for automatically detecting and remedying software lock-up conditions without user intervention. Users often refer to these conditions as “hangs” or “forever loops”. Although the Software Sanity Monitor uses the operating software's information, it is designed to execute independent of the operating system software; thereby, eliminating reliance on a “sane” operating system. If a “hang” condition is detected, the Software Sanity Monitor will automatically restart the system after logging the failure and, optionally, notify the user or host system.

I am curious if there is a way to gain access to the playbooks escreen. I tried that link and it didn't work at all.

In case this hasn't been mentioned, changes persist through reboots unlike back with the older os's. So be careful if you change stuff

Yes, the "sanity monitor" is probably what is initiating the system reboots, but it is not what is CAUSING the system reboots. Most likely the problem is whatever is going-on that causes something to stop responding which triggers the sanity monitor to restart the device.

Otherwise the device would just lock up and sit there indefinitely until the battery dies or you pull the battery. ;)

Key issues to get this working:

1) Escreen only works in landscape mode and doesn't respond to any special BB10 gestures. Just touch menu items to drill-down or change, touch left menu categories to go back.

2) Generated code must be entered QUICKLY - the uptime number changes constantly and the code generated from a specific uptime number will expire in ~20 seconds.

3) Be careful. :)

Not working for the Q10 on Verizon. If I can't figure this out, I might have to return it because the battery drain is too much at work. Did anyone get this to work on the Q10? Thanks

I got it on the Vz Q10. just had to try a couple times getting the input info for the code correct as well as typing it in quickly...

biggest thing is that I found two different "os versions" in two different places (ie, the software release in about/general and the OS version in about/OS) on my q10. I believe it was the OS version that did it. Try each of them if you're still having trouble.

whats is going on that when I want to insert APN name in escreen when I close app this name is not saved ? I don't know what I'm doing wrong :( maybe someone can help me please ?

How do I type the code in Q10? there is no "From there, two-finger swipe up to raise the keyboard and then input the code as shown".

I agree with asp006. No two finger swipe on Q10. Tried to type via keyboard and no response. Definitely entered code within 20 seconds because had PIN and OS already in so only needed to enter uptime to get code. Has anyone confirmed that the keygen works with 10.2.0.1791? Have a eliminated the ability to turn off LTE by upgrading to the leaked OS version?

3 questions:
1.i have q10 and it just has a physical keyboard not a virtual one , so its two times blind typing for me :D should i press alt before numbers? has anyone experience of that on q10?
2.is it necessary to conne
ct to net or open the code generator website in my q10 browser? can i do that on my laptop without connecting my phone to net?
3.where should i type the code? on the 'escreen://' page in my browser? on the 'help me' page that opens when i tap go after typing 'screen://' (i mean the page that contains pin,uptime,...) ? on the code generator website? on my home menu? where?
thanks

I'm not sure what to enter for "App Version:" after I reach the Help Me page. Can someone help. I own a Blackberry Z10.

SUCCESS!!! I found out from another CB post what the APP Version is...it's the operating system. (thank you whoever posted that). With that information I was able to fill out all the information required on the eScreen Keygen page mentioned above in the article (i.e. Device Pin, App Version, and Uptime). I left the Key Duration at 1-day. I then typed in the alphanumeric key that was generated by entering the above information and was brought to the Diagnostic Screen with several links listed. On the advice of someone else who posted elsewhere on the CB forum, I only tinkered with the General Radio link. I tapped on General Radio and when that page opened up, where it said APN, I simply entered the APN for my carrier (H20 Wireless), which is "att.mvno". I then got out of the Diagnostic Screen without making any other changes. Rebooted and walked two blocks from my home to get out of the range of my WiFi so I could see if I had an internet connection. I opened the browser, typed www.yahoo.com, and presto, it all worked. I never felt so proud and nerd-like in my entire life. I happen to really like this phone. Now it is fully functioning. I am very happy. :) I hope this helps others.

Im on Q10, when I access the Help Me! screen all I have is OS version - not app version. I cannot get this into the dev mode - it doesnt matter what I try!

My build is 10.2.0.1803, anyone have tips or tricks? Ive tried using the OS version on this page and from the about page but nothing works!!

Finally, so I've been googling for hours and finally found the tidbit I needed!! For some reason when entering the code into the escreen:// the ALT logo wasnt appearing - so no numbers were being entered.

Q10 Solution:
1) access escreen://
2) Create a book mark to escreen:// in the browser
3) Battery pull restart the device
4) Do not touch the keyboard !! go into escreen via shortcut
5) Alt key now works!!

Shout out to @djsvetljo who posted the fix!!

I have a Blackberry Q10 with Software Release version 10.2.1.2122
I am able to get into the escreen with no problem, but can't find anywhere to change the APN. I am not sure if the Engineering screen (escreen) has been changed in the later versions of the OS, because I do not have the same options mentioned in the comments to this article. There is no "General Radio" link/menu option.
Does anyone with Software Release version 10.2.1.2122 know where to go in the escreen to change the APN?

Thanks.

Hello

I have Z10 with the 10.2.1.2041, and I can access escreen and I found out the General Radio link.
The only thing I can do there is just change the APN name. I'm using H2O Wirless. but I cant not change anything else (or I dont know where to go and change anything else).

Any help is much welcomed.

Thanks!

thx guys this is working like a charm on my Q5. I had to _keep pressing_ the ALT the _same time_ while pressing the number keys in order to produce the numbers, not the Alt then the key (as can be entered as usual)

yea, its very hard to activate that shit... anyway it worked for me JUST now, it happened
that ALL of the code was numeric!

4 questions:
1.i have q10 and it just has a physical keyboard not a virtual one , so its two times blind typing for me :D should i press alt before numbers? has anyone experience of that on q10?
2.is it necessary to conne
ct to net or open the code generator website in my q10 browser? can i do that on my laptop without connecting my phone to net?
3.where should i type the code? on the 'escreen://' page in my browser? on the 'help me' page that opens when i tap go after typing 'screen://' (i mean the page that contains pin,uptime,...) ? on the code generator website? on my home menu? where?
4.pin is case sensetive?
thanks

Wow
I did it
And here is the solution for q10:
1.set escreen:// as a bookmark in ur browser
2.remove the battery when ur phone is turned on
3.now power on ur phone,dont press any keys
Dont type any thing
Tap on ur saved bookmark and open escreen://
4.now alt key works
attention :
*type pin in lower case
*generated code is not case sensitive
*press alt before every numbers in your code
*dont forget to use '-' before ur uptaime if its a negative number
*type the os version exactly the same of what in escreen shows
*be quick,you have only 20 secs after escreen opening
So I recommend u to use a laptop and open the code generator website in ur laptop